CD/DVD drive letters

Chitchat about x² / 2X products

Moderators: fgagnon, nikos, Site Mods

Post Reply
gkarasik
Member
Member
Posts: 57
Joined: 2014 Mar 25, 14:54

CD/DVD drive letters

Post by gkarasik » 2017 Dec 04, 16:29

Hi,

I'm wondering if anyone else is seeing this, or if I've inadvertently set some setting that's causing it:

Platform: xplorer2 ult 3501 configured as a Windows Explorer replacement, Win7 Ent/SP1, fully patched as of last Patch Tuesday, three DVD/RW drives (2 internal, 1 external). In Explorer Folder Options/View, "Hide empty drives in the Computer folder" is unchecked.

Symptoms: In the main xplorer2 Nav pain, the CD/DVD drives letters do not show up until media is in the drive. If I open My Computer. the empty drives are there, and if I open Windows Explorer itself, the empty drives are there. But the drive letters are not there in explorer2 until a disk is loaded, and they disappear as soon as the disk is removed.

I have searched in vain for an Options and Advanced Options settings that might control this and would much appreciate it if someone could try to duplicate this or if anyone has any suggestions.

GaryK
GaryK

User avatar
nikos
Site Admin
Site Admin
Posts: 14610
Joined: 2002 Feb 07, 15:57
Location: UK
Contact:

Re: CD/DVD drive letters

Post by nikos » 2017 Dec 04, 16:51

the option you need is in TOOLS > ADVANCED OPTIONS, "don't check for empty drives, list all in drivebar". It's in the global property page

gkarasik
Member
Member
Posts: 57
Joined: 2014 Mar 25, 14:54

Re: CD/DVD drive letters

Post by gkarasik » 2017 Dec 04, 17:39

Thanks, Nikos.

I can't find that item. If I go to Tools, there is only "Options." In "Options" there is an "Advanced" tab, but the choice you mention is not there. In the xplorer2 folder there is an "Advanced" icon. Clicking that closes xplorer2 and gives me choices that edit the registry, but the choice you mention is not there either. I remember an "Advanced" tab under Tools, but it is no longer showing. Is there a way to get it back?
GaryK

User avatar
nikos
Site Admin
Site Admin
Posts: 14610
Joined: 2002 Feb 07, 15:57
Location: UK
Contact:

Re: CD/DVD drive letters

Post by nikos » 2017 Dec 04, 17:51

you must have plain menus enabled. Use tools > options menu, window page to turn on the full menu and you will see it

gkarasik
Member
Member
Posts: 57
Joined: 2014 Mar 25, 14:54

Re: CD/DVD drive letters

Post by gkarasik » 2017 Dec 04, 19:15

Thank you Nikos. I found the option, and checking it solved the problem.
GaryK

Post Reply