Problem with highlighting/marquee lasso

Q & A for the old 2X Explorer file manager. For other topics, please use the corresponding forum.

Moderators: fgagnon, nikos, Site Mods

Post Reply
kellymarie
New Member
Posts: 3
Joined: 2017 Nov 23, 14:47

Problem with highlighting/marquee lasso

Post by kellymarie » 2017 Nov 23, 19:29

Hi, I hope someone can help. I've been using xplorer2 for years, but recently installed it on a new laptop and am experiencing an odd but annoying problem.

Whenever I try to highlight a group of files in either panel window - by using the marquee lasso (dragging the mouse cursor over the files I want to move/highlight) - my mouse cursor immediately moves itself to the bottom right of the screen and highlights the empty space in the panel only making highlighting impossible. I can manually click or use mouse/keyboard combinations to highlight files, but not drag a highlight lasso box around them.

Through testing, I've discovered this only happens if the columns exceed the width of the panel. So if I bunch up the columns so they don't exceed the panel window width (i.e. so there is no horizontal scrollbar in the panel) this does not happen and the highlight lasso works as normal. If my columns exceed the visible area of the panel (thus creating a horizontal scrollbar in the panel) - this is when the problem occurs.

I only have 3 columns active - Name, Size, Modified - but I have never experienced this problem on my previous computer. Furthermore I installed the free version of xplorer2 and there is no such problem in that version, nor in Windows Explorer itself or even similar products like xyplorer I tested as an alternative. I have used xplorer2 for many years and would very much like to continue doing so, but this problem is making everyday use impossible and very frustrating.

I would use the free version, but it does not show certain characters in filenames (namely Japanese) which is a problem for me and besides I bought the product and would like to a) use the full version and b) continue to support an otherwise great piece of software.

Hopefully there is a solution out there to a relatively small but frustrating problem that inhibits my use of xplorer2 in everyday use.

Thanks for any help.

User avatar
nikos
Site Admin
Site Admin
Posts: 14647
Joined: 2002 Feb 07, 15:57
Location: UK
Contact:

Re: Problem with highlighting/marquee lasso

Post by nikos » 2017 Nov 23, 20:08

another user found a similar glitch but I still cannot see it. Do you have the latest windows 10 build 16299? That could be it because mine is still the older one (MS doesn't deliver updates to Cyprus as a matter of urgency :))

kellymarie
New Member
Posts: 3
Joined: 2017 Nov 23, 14:47

Re: Problem with highlighting/marquee lasso

Post by kellymarie » 2017 Nov 24, 00:05

I am using an older version just because I had it at hand when installing on the new machine. Also my old computer was Win7.

I will install the latest version and see how it goes, thanks for the tip.

User avatar
nikos
Site Admin
Site Admin
Posts: 14647
Joined: 2002 Feb 07, 15:57
Location: UK
Contact:

Re: Problem with highlighting/marquee lasso

Post by nikos » 2017 Nov 24, 05:27

I'm puzzled with your observation that xplorer2 LITE doesn't have the problem. Can you try installing the 32 bit xplorer2 PRO and see how it does it? There is a 32/64 bit selector in the download page (next to the download buttons)
www.zabkat.com/x2down.htm

kellymarie
New Member
Posts: 3
Joined: 2017 Nov 23, 14:47

Re: Problem with highlighting/marquee lasso

Post by kellymarie » 2017 Dec 01, 14:40

Hello, thanks for your help.

I installed the 32bit version as suggested and that seems to have no such problems, so the issue is fixed I think! I suppose the 64bit version would be preferable, but since there's no noticable difference for myself - I'm happy to continue using the 32bit version. It is odd that on my old Win7 PC the 64bit version worked just fine, so I will put this down to a kink of Windows 10 and it not liking something about the 64bit version of xplorer2.

Thanks for your help, I'm so glad to have the program working again - I use it so often I was lost without it! :)

User avatar
nikos
Site Admin
Site Admin
Posts: 14647
Joined: 2002 Feb 07, 15:57
Location: UK
Contact:

Re: Problem with highlighting/marquee lasso

Post by nikos » 2017 Dec 02, 06:14

xplorer2 is not alone with this bug, all software that use listview controls have it:
https://sourceforge.net/p/sevenzip/disc ... /?limit=25

only 32 bit programs work ok, 64 bit are stuffed
I just received the win10 update 16299 and I see the problem. Not sure if I can do anything about it though... still looking

Post Reply