spaces in paths and files - error

Questions & Answers

Moderators: fgagnon, nikos, Site Mods

Post Reply
sarmas
New Member
Posts: 2
Joined: 2002 May 26, 16:51

Post by sarmas » 2002 May 26, 17:03

im using editor2 in windows 98 se (english) and its giving me errors when handling files and path with spaces or even when editor2 is installed in a path with spaces. im using a portuguese keybord.

User avatar
nikos
Site Admin
Site Admin
Posts: 14670
Joined: 2002 Feb 07, 15:57
Location: UK
Contact:

Post by nikos » 2002 May 26, 19:45

that's most probably because you didn't associate ed2 with text files as recommended in editor2.txt. You need to add "%1" (including the quotation marks after the program name. See editor2.txt for more info (or FAQ#10)

sarmas
New Member
Posts: 2
Joined: 2002 May 26, 16:51

Post by sarmas » 2002 May 26, 22:53

many thanks. i guess this is a newby kinda problem. ive now read editor2.txt and in fact it is very clear about this. its working great now! thanks again ;)

HeadInTheClouds
New Member
Posts: 2
Joined: 2002 Aug 26, 09:52

Post by HeadInTheClouds » 2002 Aug 26, 10:24

:spin:
I had the same problem, and being typically impatient, didn't read the help.
Windows 2000, options doesn't apparently default the "%" symbol, it does need to be added:
"C:\Program Files\2X Editor\Editor2.exe" "%1"
now all is well and good.
Great program, and 2X Explorer could save me alot of time too, thanks
Nicos.

User avatar
nikos
Site Admin
Site Admin
Posts: 14670
Joined: 2002 Feb 07, 15:57
Location: UK
Contact:

Post by nikos » 2002 Aug 26, 12:39

this must be the most frequent question i receive, perhaps one in every three or four!

so i've decided that in the next version the whole command line will be considered as a single path, unless some command line option like /V is used. That should make things easier for 95% of users

Post Reply