Tag color order messed up

Discussion & Support for xplorer² professional

Moderators: fgagnon, nikos, Site Mods

Post Reply
BrianS
New Member
Posts: 3
Joined: 2021 Jun 09, 23:48

Tag color order messed up

Post by BrianS » 2021 Jun 11, 02:31

Running 5.0.0.2 ULT x64

I added some extra colors to the Color tags in the registry some time ago - all worked fine until the update to 5.0.0.2
Here are the registry entries
Image

However in the XP2 menu the list displays in a different sequence as follows:
Note 'Yellow' is tag # 6 but instead Dark Blue is listed, if I choose Dark Blue I still get Yellow :shock:

Image

Brian

User avatar
nikos
Site Admin
Site Admin
Posts: 15072
Joined: 2002 Feb 07, 15:57
Location: UK
Contact:

Re: Tag color order messed up

Post by nikos » 2021 Jun 11, 05:13

sorry I can't reproduce that
registry shows the values sorted alphabetically, but that's not an issue
did you lately import your settings from a different PC?
have you tried a reboot?

BrianS
New Member
Posts: 3
Joined: 2021 Jun 09, 23:48

Re: Tag color order messed up

Post by BrianS » 2021 Jun 12, 03:35

Nikos,
No import form other PC, just the upgrade.
Have tried reboot.

The menu listing was fine until the last update, then the color names were not in the right order.
Also, I initially had 2 x 'Dark Blue'. I found this in the registry as well, removed the duplicate in the registry and that removed it in the menu list.

Files / folders retain the correct colour tag (if you pick the right menu entry i.e. Yellow is 6th entry in registry , use the 6th entry in the menu and you get yellow and the tag column shows 6).

So I guess the tag database is Ok? Should I try uninstalling / reinstal?

Brian

User avatar
nikos
Site Admin
Site Admin
Posts: 15072
Joined: 2002 Feb 07, 15:57
Location: UK
Contact:

Re: Tag color order messed up

Post by nikos » 2021 Jun 12, 04:02

if you removed a color entry from the registry, that will affect the OLD colors, since they are assigned by order (0,1,2,...). But new items shouldn't be affected, whatever color you see in the menu is the color that is assigned.

if that doesn't work for you then it is very spooky! Is it only yellow that has the problem?

BrianS
New Member
Posts: 3
Joined: 2021 Jun 09, 23:48

Solved: Tag color order messed up

Post by BrianS » 2021 Jun 18, 01:06

Hi Nik,
All colors were messed up not just Yellow.

I checked an old settings.reg backup with the default 3 colors (pre my use of extra colors), and comparead that to a fresh one - voila - the color sequence was incorrect. So I just edited the fresh settings.reg file and then imported it into x2 and problem solved.

Interestingly it appears the values/sequence in the registry was only 'visually' overridden when x2 opens, although the actual registy values are loaded as per the registry, e.g. value 6 was yellow, but showed showed dark blue in 6th place the menu, but if you chose dark blue yuou would get yellow :shock:

Any how, all fixed now.

User avatar
nikos
Site Admin
Site Admin
Posts: 15072
Joined: 2002 Feb 07, 15:57
Location: UK
Contact:

Re: Tag color order messed up

Post by nikos » 2021 Jun 18, 15:19

do you by any chance save settings in INI files instead of registry?

Post Reply