Page 1 of 1

Delete keyboard option not working?

Posted: 2019 Dec 10, 19:59
by teknowledgist
I am no longer able to delete files using the <del> key!? It works fine on the desktop (i.e. with Explorer), but within Xplorer2, nothing happens. When I check the Customize -> Keyboard Use, there is no delete item appearing. When I go to set it in Customize -> Keyboard, there is no "Delete" item in the "File" menu list. When I look at Help -> Command Finder and search for delete, the File>Delete item appears and the text description starts with "<Del>:..." which tells me it is supposed to be set.

I'm pretty sure something is broken. How do I get it re-set?

(Win10 1809, Xplorer2 4.3.0.1)

Thanks.

Re: Delete keyboard option not working?

Posted: 2019 Dec 11, 06:49
by nikos
DEL is a special key that cannot be changed with CUSTOMIZE > KEYBOARD menu command, but if you see <DEL> in the command finder, then it should work. Do you have problems with any other keyboard shortcuts? E.g. does CTRL+C work when Del doesn't?

Re: Delete keyboard option not working?

Posted: 2019 Dec 11, 13:09
by teknowledgist
Huh! You're correct. I can no longer copy/paste with the keyboard, nor can I clone the window (ctrl-shift-w). I can however select all (ctrl-A), search (F3), refresh (F5), rename (F2), and edit (F4). What is going on??

Thanks.

Re: Delete keyboard option not working?

Posted: 2019 Dec 11, 16:39
by nikos
looks like some screwup with the keyboard assignments? Can you export your settings in a REG file, zip it and email it to me?

Re: Delete keyboard option not working?

Posted: 2019 Dec 11, 20:28
by teknowledgist
nikos wrote:
2019 Dec 11, 16:39
looks like some screwup with the keyboard assignments? Can you export your settings in a REG file, zip it and email it to me?
Actually, I can't. I get a 0kB file when I export settings. It's something that has been a minor frustration with my use of Xplorer2 for years, but not worth looking for a "fix" since I so rarely need it. I assume it is because I run as a non-admin (as is recommended) and/or the forced GPO settings blocking reg.exe/regedit.exe. If that should be working, suggestions for fixing it are welcome too. :D

Now, I do have the ability to run things with admin credentials, and I can get into my registry hive if you can identify where I should be looking. I just can't "export" from within Xplorer2 under my user account for whatever reason. I poked around in the 'Software\ZabaraKatranemia Plc' key, but didn't see anything related to keyboard shortcuts.

Thanks.

Re: Delete keyboard option not working?

Posted: 2019 Dec 12, 06:28
by nikos
if you blocked regedit then export/import won't work, but you can use the standalone regedit, locate the main settings registry key (let's say the entire HKCU\Software\ZabaraKatranemia Plc), right click on it and use EXPORT from the menu. Then you can send me this REG file (zipped)

if you want to pin it down, I need binShortcuts value, so you only need to export HKCU\Software\ZabaraKatranemia Plc\xplorer2_UC.global

Re: Delete keyboard option not working?

Posted: 2019 Dec 12, 15:39
by nikos
thanks for the settings file. FIrst of all a correction, the keyboard shortcuts are in a key called xplorer2_UC.global\Accelerators not binShortcuts. Then I can see that most of the default shortcut keys have been erased (including DEL and Ctrl+C) which explains why they wont work!

did you remove these yourself or was there some sort of snag?

anyway, use CUSTOMIZE > KEYBOARD menu command and click on the RESET button to get back all the default keys. Then you can add all your changes like F5 for refreshing etc. In the end, backup your settings with regedit and you should be ok

Re: Delete keyboard option not working?

Posted: 2019 Dec 13, 15:14
by teknowledgist
nikos wrote:
2019 Dec 12, 15:39
did you remove these yourself or was there some sort of snag?
Unless there is a key command that I fat-fingered, I did not remove anything. I think this was happening on 2 of my 3 machines too although now that I've gone and "fixed" it, I can't be entirely certain about that.

Nevertheless, I am back in business. Thanks!