Updated, now starts open with Win10

Discussion & Support for xplorer² professional

Moderators: fgagnon, nikos, Site Mods

Post Reply
point
Member
Member
Posts: 16
Joined: 2014 Dec 07, 13:07

Updated, now starts open with Win10

Post by point » 2020 May 11, 11:17

Recently updated (4.4.0.1 x64), and each time Windows 10 boots, xplorer2 is open on the desktop. It wasn't open on shutdown, and it hadn't been doing this before the update. It added a startup folder entry (not sure if this existed before) of "C:\Program Files\zabkat\xplorer2\xplorer2_64.exe" /M
I'm fairly certain this has happened to me before, a long while ago, but can't find the post or email with the solution.

Any thoughts on the cause and more importantly, the fix?

point
Member
Member
Posts: 16
Joined: 2014 Dec 07, 13:07

Re: Updated, now starts open with Win10

Post by point » 2020 May 11, 11:27

As usual, I find my post as soon as I start a new thread. Last time this happened was in 2014, and Windows 7.
Then, it was several entries in startup, this time it might be the flag in there was incorrectly set to "/M" by the installer. That's "Does not allow window to open in minimized mode on startup", clearly not right.

The flag should be /Z (Silently start and stay in the background without a window), which will hopefully put this back to normal.

User avatar
nikos
Site Admin
Site Admin
Posts: 14645
Joined: 2002 Feb 07, 15:57
Location: UK
Contact:

Re: Updated, now starts open with Win10

Post by nikos » 2020 May 11, 13:09

perhaps you ticked the new installer option "start xplorer2 with windows"?

point
Member
Member
Posts: 16
Joined: 2014 Dec 07, 13:07

Re: Updated, now starts open with Win10

Post by point » 2020 May 12, 11:48

I think I may have. Without reinstalling, is there a fix, like maybe just removing the startup menu link?
Using the /Z startup flag didn't do anything, either.

Just reinstalled, and it didn't touch the startup entry. ;)

User avatar
nikos
Site Admin
Site Admin
Posts: 14645
Joined: 2002 Feb 07, 15:57
Location: UK
Contact:

Re: Updated, now starts open with Win10

Post by nikos » 2020 May 12, 13:24

remove the startup entry and you won't see it again. Otherwise uninstall then reinstall

point
Member
Member
Posts: 16
Joined: 2014 Dec 07, 13:07

Re: Updated, now starts open with Win10

Post by point » 2020 May 13, 10:49

Just removed it, thanks. Interesting side note, after reinstalling yesterday, making sure that wasn't checked, booted this morning and had 2 xplorer2 windows open. I'll see if it helps removing from the startup, and if not, maybe I need to fiddle in the registry.

User avatar
nikos
Site Admin
Site Admin
Posts: 14645
Joined: 2002 Feb 07, 15:57
Location: UK
Contact:

Re: Updated, now starts open with Win10

Post by nikos » 2020 May 13, 14:17

I don't know why this happens to some people but the certain remedy is to not replace windows explorer with xplorer2 (that's when xplorer2 also starts every time but stays hidden)

point
Member
Member
Posts: 16
Joined: 2014 Dec 07, 13:07

Re: Updated, now starts open with Win10

Post by point » 2020 May 14, 10:21

Back to a single open window on boot after removing from the startup folder. :roll:

As for not telling it to replace Windows Explorer? That's kind of the point to using this, isn't it?
I'd like this to show up as much as possible, and it seems counter intuitive to shut that off.

User avatar
nikos
Site Admin
Site Admin
Posts: 14645
Joined: 2002 Feb 07, 15:57
Location: UK
Contact:

Re: Updated, now starts open with Win10

Post by nikos » 2020 May 14, 12:36

if you start xplorer2 and never close it, it's the same thing isn't it?

point
Member
Member
Posts: 16
Joined: 2014 Dec 07, 13:07

Re: Updated, now starts open with Win10

Post by point » 2020 May 15, 20:22

> if you start xplorer2 and never close it, it's the same thing isn't it?

Never close it? I don't leave xplorer2 windows open all day, I'm in fact trying to get it to open only when asked. Have I misunderstood your meaning?

point
Member
Member
Posts: 16
Joined: 2014 Dec 07, 13:07

Re: Updated, now starts open with Win10

Post by point » 2020 May 17, 00:24

Well, nothing has worked. Rolled back a version, reinstalled that and chose not to replace Explorer, reinstalled latest without replacing, then with...nothing seems to get rid of the open window on startup; it's refusing to go back to how it was just a little while ago.
Very annoying.

Open to suggestions.

User avatar
nikos
Site Admin
Site Admin
Posts: 14645
Joined: 2002 Feb 07, 15:57
Location: UK
Contact:

Re: Updated, now starts open with Win10

Post by nikos » 2020 May 17, 07:43

use your task manager, it has a STARTUP tab, whatever you find in there with xplorer2 make it disabled

point
Member
Member
Posts: 16
Joined: 2014 Dec 07, 13:07

Re: Updated, now starts open with Win10

Post by point » 2020 May 18, 19:22

Thanks, Nikos. Didn't think to look there (as it was in startup, as well as "run" in the registry), but that did the trick. No more window on boot. :D

Post Reply