Page 1 of 1

"sort" does not work correctly

Posted: 2020 Jun 20, 14:48
by Manyx
Hi,
With Xplorer 4.4 and Windows 10, there is 2 ways of sort.
- Not natural: 1 ; 10 ; 2 ; 3
- Natural: 1 ; 2 ; 3 ; ... ; 10

But the natural sort has the same bug as MS explorer:
F-01
F-02
F2
F-03
F3

instead of : F-01 ; F-02 ; F-03 ; F2 ; F3
Am I doing something wrong?

Re: "sort" does not work correctly

Posted: 2020 Jun 20, 16:35
by nikos
that's the way it goes in "natural" number sort it seems!

Re: "sort" does not work correctly

Posted: 2020 Jun 20, 17:01
by Manyx
With Windows XP and MS Explorer, no problem, it was the good sorting:
F-01
F-02
F-03
F2
F3

And now with Windows 10 I see this bug in MS Explorer, and in some alternatives explorers like Xplorer. But some other alternatives have not this bug.

Re: "sort" does not work correctly

Posted: 2020 Jun 21, 06:41
by nikos
it is questionable whether this is a bug, some would say that this is what number mode is all about. For best results use proper alphanumeric sort and add leading zeros as required

Re: "sort" does not work correctly

Posted: 2020 Jun 21, 09:44
by Manyx
I think that it's not questionable :)
F-01
F-02
F2
F-03
F3
this current sort works as if there was no dash.

Re: "sort" does not work correctly

Posted: 2020 Jun 21, 10:02
by Robert2

Re: "sort" does not work correctly

Posted: 2020 Jun 24, 16:59
by Manyx
nikos wrote: ↑
2020 Jun 21, 06:41
For best results use proper alphanumeric sort and add leading zeros as required
yes, but here it is not the problem. I have no folder above F9. The problem is that the sort don't see the dash.

If I add a zero, the result is the same:
F-01
F-02
F02
F-03
F03

instead of:
F-01
F-02
F-03
F02
F03

I don't have this bug with Windows XP. It seems to be a Windows 10 bug, that is sometimes corrected in some alternative file explorers (not all).

If i uncheck "natural number", the sort is good, it sorts with the dash.
What is the reason to forget the dash in natural number sort? Here is the result without numbers (natural sort):
F-AA
FB
F-BB
FC
F-CC

If I uncheck "natural" : il is the same! It seams that the sort sees the dash when it is unnatural AND when there are numbers... :roll:

Re: "sort" does not work correctly

Posted: 2020 Jun 25, 04:28
by nikos
natural number sort is provided by windows, so I cannot change this behavior. Personally I find that adding somewhere dashes and other places not, is inviting problems of this sort. For best results have a homogenous naming convention, either use dashes or not, or don't expect them to align properly

Re: "sort" does not work correctly

Posted: 2020 Jun 26, 21:12
by Manyx
I got around the MicroSoft bug: _ instead of -

Now, with natural order in Windows 10:
F_01
F_02
F_03
F_A
F_B
F02 (or F2)
F03 (or F3)
FA
FB
:bigsmile: