1.0.0.94 delete bug?

Discussion & Support for xplorer² professional

Moderators: fgagnon, nikos, Site Mods

Post Reply
Rhino
Member
Member
Posts: 20
Joined: 2004 Oct 09, 07:00

1.0.0.94 delete bug?

Post by Rhino » 2004 Oct 15, 08:08

Hi,

Imagine I have a folder structure like this:

C:\A\B


And in the treeview I have B hilighted.

When I hit Shift+Delete to delete B the focus in the treeview goes to Desktop instead of emulating Explorer's behaviour which goes to A.


Rhino.

User avatar
nikos
Site Admin
Site Admin
Posts: 15013
Joined: 2002 Feb 07, 15:57
Location: UK
Contact:

Post by nikos » 2004 Oct 15, 08:15

this is an imperfect world we're living in :)

Rhino
Member
Member
Posts: 20
Joined: 2004 Oct 09, 07:00

Post by Rhino » 2004 Oct 15, 08:21

lol ... could be worse ... you could be coding in WTL ;)


Seriously though it's a PITA when you have your treeview expanded a lot since it jumpts to the top and you have to scroll down to get back to where you were. Can I expect it to be fixed in the near future?

User avatar
nikos
Site Admin
Site Admin
Posts: 15013
Joined: 2002 Feb 07, 15:57
Location: UK
Contact:

Post by nikos » 2004 Oct 15, 10:18

when i try it myself it won't switch to the desktop
you must have these settings:
* tree auto syncs with active folder
* you are browsing the folder you are deleting

as a result, when you delete B the view goes to the desktop and the tree follows. All your fault you could say :)

don't forget that to bring the tree back where you are you only need to Alt+T from your active folder

Rhino
Member
Member
Posts: 20
Joined: 2004 Oct 09, 07:00

Post by Rhino » 2004 Oct 15, 10:26

Hi Nikos,

You are right that I have the sync flag set and I am viewing the folder.

However when I switched off sync the problem is sort of "worse" in that after the delete the listview populates itself with all the items I have in Desktop (a lot), then clears and displays the contents of A.

So it's not my fault ... honest! :D :D

Post Reply