4.2.01 Assistance

Discussion & Support for xplorer² professional

Moderators: fgagnon, nikos, Site Mods

Post Reply
Uzer99
New Member
Posts: 6
Joined: 2019 Jun 13, 14:05

4.2.01 Assistance

Post by Uzer99 » 2019 Jul 25, 19:24

Hello,

Windows 10 Education (x64) Build 17134.829 up to date
Intel I7-7700 2.8GHz
32gb Ram


I'm a new user currently trialling 4.2.01 Ultimate version. I have it installed into a single folder for portable use with registry saved into the installation folder. Via xplorer2 preview function, I can see binary view of files and images of jpg and gif files. The issue is the embedded windows media player. Whenever a media file is selected to play, xplorer2 invokes Werfault.exe and crashes.

I updated to the latest KLite Standard Klite Codec pack but x2 media player still didnt work. I then entirely removed Klite Codec pack, ran registry cleaner, and retried x2 windows media player but x2 still crashes on any mp4 file played. Mp3 play fine.

I have tried to get the Last Error and Crash Information through the Help function but it says "There is no crash dump file for this program version. Windows error =50. The request is not supported". After checking through the x2 forum, the program Procdump was suggested to be used to make a dump file. I tried this program and could only get a dump file while the program was active, not when it was in the process of crashing or crashed.

Can someone provide some assistance to fix this problem? Below is the console output. Thanks

Edit: 7.25.19 8:15pm ET I also checked in the AppData Temp folder %TEMP%\x2minidump*.mdmp and there are no .mdmp files present.



PS C:\Procdump> .\procdump -e -r -h -ma xplorer2_64.exe
ProcDump v9.0 - Sysinternals process dump utility
Copyright (C) 2009-2017 Mark Russinovich and Andrew Richards
Sysinternals - www.sysinternals.com

Process: xplorer2_64.exe (17196)
Process image: C:\Users\XXX\Documents\x2test\xplorer2_64.exe
CPU threshold: n/a
Performance counter: n/a
Commit threshold: n/a
Threshold seconds: 10
Hung window check: Enabled
Log debug strings: Disabled
Exception monitor: Unhandled
Exception filter: [Includes]
*
[Excludes]
Terminate monitor: Disabled
Cloning type: PSS
Concurrent limit: 1
Avoid outage: Disabled
Number of dumps: 1
Dump folder: C:\Procdump\
Dump filename/mask: PROCESSNAME_YYMMDD_HHMMSS
Queue to WER: Disabled
Kill after dump: Disabled


Press Ctrl-C to end monitoring without terminating the process.

[14:44:49] Exception: 000006BA
[14:45:02] Exception: 40080201
[14:45:03] The process has exited.
[14:45:03] Dump count not reached.
Last edited by Uzer99 on 2019 Jul 26, 22:47, edited 2 times in total.

User avatar
nikos
Site Admin
Site Admin
Posts: 14407
Joined: 2002 Feb 07, 15:57
Location: UK
Contact:

Re: 4.2.01 Assistance

Post by nikos » 2019 Jul 26, 16:44

I am aware that for a minority of people the embedded media player crashes. Unfortunately on my system it doesn't do it so I cannot fix the problem. I hope when I get the latest windows 10 update it may crash on me more reliably. For the time being I can recommend turning off the autoplay option in xplorer2 (TOOLS > OPTIONS menu, Window property page), so at least it won't crash on you by accident

Uzer99
New Member
Posts: 6
Joined: 2019 Jun 13, 14:05

Re: 4.2.01 Assistance

Post by Uzer99 » 2019 Jul 26, 22:35

RE: zabkat support forum: Post 4.2.01 Assistance

I found the dump folder. It was not under AppData Local Temp, just AppData Local in a newly created folder called CrashDumps. Please review the attached dumps from the crashed xplorer2 application.

Thanks

xdump.zip and xdump2.zip emailed to support@zabkat.com

User avatar
nikos
Site Admin
Site Admin
Posts: 14407
Joined: 2002 Feb 07, 15:57
Location: UK
Contact:

Re: 4.2.01 Assistance

Post by nikos » 2019 Jul 26, 22:57

thanks, this is what I got from the others too, I hope to be able to reproduce it soon

Uzer99
New Member
Posts: 6
Joined: 2019 Jun 13, 14:05

Re: 4.2.01 Assistance

Post by Uzer99 » 2019 Jul 27, 15:30

Addl info:

Prior to trying 4.201, I used the following plugins in an earlier version of xplorer2 (3.4.0.4). When 3404 would crash via the preview, I thought the issue might be fixed in the latest version and got 4201. Some of the plugins remained on the computer when I installed 4201. When I noticed the media player still crashing, I uninstalled icaros since it was a relevant media (mp4) plugin but it didnt stop xplorer2 from crashing.

audioshell236.exe
ebookinfowdx-104
epubfilter
epubthumbs
icaros v311b1
pxcviewer_x64
x2pluginconsul
Last edited by Uzer99 on 2019 Jul 27, 16:04, edited 1 time in total.

User avatar
nikos
Site Admin
Site Admin
Posts: 14407
Joined: 2002 Feb 07, 15:57
Location: UK
Contact:

Re: 4.2.01 Assistance

Post by nikos » 2019 Jul 27, 16:03

strictly speaking it is WMP that is crashing but since it is hosted by xplorer2, it takes down xplorer2 as well :shrug:

Uzer99
New Member
Posts: 6
Joined: 2019 Jun 13, 14:05

Re: 4.2.01 Assistance

Post by Uzer99 » 2019 Jul 27, 16:07

Yes, that seems to be accurate re the source of the crash. However, it still needs to be determined why files that play normally in WMP native will not play inside xplorer2 and cause it to crash.

Uzer99
New Member
Posts: 6
Joined: 2019 Jun 13, 14:05

Re: 4.2.01 Assistance

Post by Uzer99 » 2019 Jul 28, 15:34

Update:

All x2 plugins uninstalled and application is still crashing. Latest log attached.

fwd email to support@zabkat.com

User avatar
nikos
Site Admin
Site Admin
Posts: 14407
Joined: 2002 Feb 07, 15:57
Location: UK
Contact:

Re: 4.2.01 Assistance

Post by nikos » 2019 Jul 28, 17:36

xplorer2 plugins aren't related to this crash, so either way won't make a difference

Uzer99
New Member
Posts: 6
Joined: 2019 Jun 13, 14:05

Re: 4.2.01 Assistance

Post by Uzer99 » 2019 Aug 11, 20:17

I have a version of x2 3404 that works fine in Windows 8.1 that when moved to Win10 machine x2 wmp fails. The x2 4.201 when moved from the win10 machine to win 8.1 works. Something in Win10 is making wmp fail. KLite Codecs have been updated and verified good on win10 and win 8.1 (same current version).

Any hint from the supplied error logs re a solution for this problem?

User avatar
nikos
Site Admin
Site Admin
Posts: 14407
Joined: 2002 Feb 07, 15:57
Location: UK
Contact:

Re: 4.2.01 Assistance

Post by nikos » 2019 Aug 11, 23:03

to be honest I don't have a clue. I know some people have consistent problems with WMP, and I was hoping that after I got the latest windows 10 update, it would start crashing for me too, but now I have the latest 10.0-18362 and still it doesn't crash. So it's going to be a very hard bug to pin down :(

Post Reply