xplorer² Cannot copy/move files to Synology NAS via UNC

Discussion & Support for xplorer² professional

Moderators: fgagnon, nikos, Site Mods

Post Reply
User avatar
luma
Member
Member
Posts: 11
Joined: 2012 Mar 14, 17:19

xplorer² Cannot copy/move files to Synology NAS via UNC

Post by luma » 2019 Dec 15, 12:51

I have a weird problem that I can't seem to sort out and would appreciate some help. I'm using a Synology NAS server for file sharing. The Synology is AD integrated and I am authenticated as a Domain Admin account. When I am interacting with a file share as a UNC in xplorer² (4.3.0.1 ULT x64), I am unable to copy or move files to the NAS, but only when connected to that share using a UNC. In all cases, performing the same action in Windows explorer with the same source and target works as expected. Creating new folders and files with xplorer² also works as expected.

Here as some example situations:

xplorer² copy via ctrl+c/ctrl+v from local drive to NAS folder connected via UNC: failed (error beep, no message)
xplorer² copy via built-in copy command (F5) from local drive to NAS folder connected via UNC: failed (error beep, no message)
xplorer² copy via ctrl+c/ctrl+v from local drive to NAS folder connected via mapped drive: success
xplorer² copy via built-in copy command (F5) from local drive to NAS folder connected via mapped drive: success
xplorer² copy from NAS folder to NAS folder via UNC: failed (error beep, no message)
xplorer² create new file or folder via right-click to NAS folder via UNC: success
windows explorer copy via ctrl+c/ctrl+v from local drive to NAS folder connected via UNC: success

User avatar
nikos
Site Admin
Site Admin
Posts: 14644
Joined: 2002 Feb 07, 15:57
Location: UK
Contact:

Re: xplorer² Cannot copy/move files to Synology NAS via UNC

Post by nikos » 2019 Dec 16, 07:04

I don't really know what to recommend as I don't have such a setup to test. Are you running xplorer2 normally or elevated (as administrator). Does it make any difference either way?

User avatar
luma
Member
Member
Posts: 11
Joined: 2012 Mar 14, 17:19

Re: xplorer² Cannot copy/move files to Synology NAS via UNC

Post by luma » 2019 Dec 16, 14:08

That is an interesting question, so I just went and tested and the results are the same launching normally or elevated. While checking the shortcut to launch I also tested Compatibility mode with no change in behavior.

With further testing, it turns out this behavior is experience with _all_ UNC targets, not just the Synology. Testing against Windows Server 2012, 2016, and 2019 all produce the same message, while the same test using Windows Explorer (or PowerShell CLI) works as expected.

Another thing I just noticed is that an error message appears in the lower left corner of xplorer2 when attempting to copy into a UNC-connected folder.

When attempting to copy to a UNC target via Ctrl+V: "Paste from clipboard failed"
When attempting to copy to a UNC target via F6: "The target folder does not accept this file operation"

Is there any way to light up debug logging by chance? This behavior has been consistent (meaning, it never works and hasn't for a while now) and is isolated to xplorer²

User avatar
luma
Member
Member
Posts: 11
Joined: 2012 Mar 14, 17:19

Re: xplorer² Cannot copy/move files to Synology NAS via UNC

Post by luma » 2019 Dec 16, 14:29

Further testing:

I run Ultimate in portable mode, which is then synced across several systems. I can confirm that a couple other systems utilizing this portable install experience the same behavior.

Wondering if maybe portable mode was my problem, I downloaded a new installer and installed xplorer2 locally on my primary desktop and am still experiencing the same problem. This is now happening on two separate Windows 10 installations, one of which was installed clean on Saturday.

User avatar
nikos
Site Admin
Site Admin
Posts: 14644
Joined: 2002 Feb 07, 15:57
Location: UK
Contact:

Re: xplorer² Cannot copy/move files to Synology NAS via UNC

Post by nikos » 2019 Dec 16, 16:31

is the problem just with root folders? Will xplorer2 paste in deeper subfolders in those UNC paths?

User avatar
luma
Member
Member
Posts: 11
Joined: 2012 Mar 14, 17:19

Re: xplorer² Cannot copy/move files to Synology NAS via UNC

Post by luma » 2019 Dec 16, 20:23

I hadn't tested that until now but you are spot-on - this behavior is only experienced at root folders.

\\nas01\xplorer: copy failed
\\nas01\xplorer\test: copy succeeded
X:\ mapped to \\nas01\xplorer: copy succeeded
X:\ mapped to \\nas01\xplorer\test: copy succeeded

User avatar
nikos
Site Admin
Site Admin
Posts: 14644
Joined: 2002 Feb 07, 15:57
Location: UK
Contact:

Re: xplorer² Cannot copy/move files to Synology NAS via UNC

Post by nikos » 2019 Dec 17, 07:07

can you download and run this test version and see if it works on root folders too?
www.zabkat.com/test/xplorer2_test.zip

User avatar
luma
Member
Member
Posts: 11
Joined: 2012 Mar 14, 17:19

Re: xplorer² Cannot copy/move files to Synology NAS via UNC

Post by luma » 2019 Dec 17, 15:02

With the test version it's now half-working! File copy using the built-in F5 copy tool now works when copying to a UNC root folder. Copy using ctrl+C then ctrl+V in the target folder still fails when pasting to a UNC root. Copying to a non-root UNC folder still works as expected using both methods.

edit: log output sent via PM

User avatar
nikos
Site Admin
Site Admin
Posts: 14644
Joined: 2002 Feb 07, 15:57
Location: UK
Contact:

Re: xplorer² Cannot copy/move files to Synology NAS via UNC

Post by nikos » 2019 Dec 17, 15:38

thanks for the information, logs etc
I can see how ctrl+c/V fails, but I don't want to change it. You can use F5 or drag-drop for the root folder. Alternatively, use TOOLS > ADVANCED OPTIONS menu and tick the option "Perform Edit > Paste robustly...", then it will work too!

I will release a bugfix shortly

User avatar
nikos
Site Admin
Site Admin
Posts: 14644
Joined: 2002 Feb 07, 15:57
Location: UK
Contact:

Re: xplorer² Cannot copy/move files to Synology NAS via UNC

Post by nikos » 2019 Dec 17, 16:35

4302 is released, use HELP > CHECK FOR UPDATES menu command

User avatar
luma
Member
Member
Posts: 11
Joined: 2012 Mar 14, 17:19

Re: xplorer² Cannot copy/move files to Synology NAS via UNC

Post by luma » 2019 Dec 17, 16:44

WOW! Thank you so much man, this works great now!

Is there a downside to the "paste robustly" option? It works as expected, but your response (and the fact that it's default off, and buried under advanced options) suggests that maybe it may involve some other problems I don't understand.

User avatar
nikos
Site Admin
Site Admin
Posts: 14644
Joined: 2002 Feb 07, 15:57
Location: UK
Contact:

Re: xplorer² Cannot copy/move files to Synology NAS via UNC

Post by nikos » 2019 Dec 18, 06:37

there's no problem with robust paste, it works just like F5. If you need to use the windows explorer copy/paste you can do drag-drop

Post Reply